CVE-2011-4102

NameCVE-2011-4102
DescriptionHeap-based buffer overflow in the erf_read_header function in wiretap/erf.c in the ERF file parser in Wireshark 1.4.0 through 1.4.9 and 1.6.x before 1.6.3 allows remote attackers to cause a denial of service (application crash) via a malformed file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2351-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie1.12.1+g01b65bf-4+deb8u11fixed
jessie (security)1.12.1+g01b65bf-4+deb8u12fixed
stretch2.2.6+g32dac6a-2fixed
stretch (security)2.2.6+g32dac6a-2+deb9u1fixed
buster, sid2.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.6.3-1medium
wiresharksourcelenny1.0.2-3+lenny16mediumDSA-2351-1
wiresharksourcesqueeze1.2.11-6+squeeze5mediumDSA-2351-1

Notes

http://www.wireshark.org/security/wnpa-sec-2011-19.html
http://anonsvn.wireshark.org/viewvc/trunk/wiretap/erf.c?r1=39508&r2=39507&pathrev=39508&view=patch
Affects 1.0 and 1.2, the versions listed in the advisory are relative to the supported upstream branches

Search for package or bug name: Reporting problems