CVE-2011-4107

NameCVE-2011-4107
DescriptionThe simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2391-1
NVD severitymedium (attack range: remote)
Debian Bugs656247
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)squeeze, squeeze (security)4:3.3.7-7fixed
squeeze (lts)4:3.3.7-8fixed
wheezy (security), wheezy4:3.4.11.1-2+deb7u1fixed
jessie4:4.2.12-2fixed
stretch, sid4:4.4.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:3.4.7.1-1medium656247
phpmyadminsourcelenny(not affected)
phpmyadminsourcesqueeze4:3.3.7-7mediumDSA-2391-1

Notes

[lenny] - phpmyadmin <not-affected> (Vulerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=751112

Search for package or bug name: Reporting problems