DescriptionBuffer overflow in the ccid_card_vscard_handle_message function in hw/ccid-card-passthru.c in QEMU before 0.15.2 and 1.x before 1.0-rc4 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted VSC_ATR message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u25fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u3fixed
buster, sid1:2.12~rc3+dfsg-2fixed
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-13fixed
jessie (security), jessie4.4.1-9+deb8u10fixed
buster, sid, stretch (security), stretch4.8.3+comet2+shim4.10.0+comet3-1+deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcelenny(not affected)
qemusourcesqueeze(not affected)
xensourcewheezy(not affected)


[lenny] - qemu <not-affected> (Vulnerable CCID code not present)
[squeeze] - qemu <not-affected> (Vulnerable CCID code not present)
[wheezy] - xen <not-affected> (Vulnerable code introduced after 0.14.50, embedded version is 0.10.2)
Xen switched to qemu-system in 4.4.0-1
Vulnerable code introduced after 0.14.50:;a=commit;h=edbb21363fbfe40e050f583df921484cbc31c79d

Search for package or bug name: Reporting problems