CVE-2011-4130

NameCVE-2011-4130
DescriptionUse-after-free vulnerability in the Response API in ProFTPD before 1.3.3g allows remote authenticated users to execute arbitrary code via vectors involving an error that occurs after an FTP data transfer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2346-1, DSA-2346-2
NVD severityhigh
Debian Bugs648373

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)stretch1.3.5b-4+deb9u5fixed
stretch (security)1.3.5e+r1.3.5b-4+deb9u2fixed
buster1.3.6-4+deb10u5fixed
buster (security)1.3.6-4+deb10u4fixed
bullseye, sid1.3.7a-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsourcelenny1.3.1-17lenny9DSA-2346-2
proftpd-dfsgsourcesqueeze1.3.3a-6squeeze4DSA-2346-1
proftpd-dfsgsource(unstable)1.3.4~rc3-2high648373

Notes

[lenny] - proftpd-dfsg <not-affected> (vulnerable functionality not present)
http://bugs.proftpd.org/show_bug.cgi?id=3711

Search for package or bug name: Reporting problems