CVE-2011-4350

NameCVE-2011-4350
DescriptionYaws 1.91 has a directory traversal vulnerability in the way certain URLs are processed. A remote authenticated user could use this flaw to obtain content of arbitrary local files via specially-crafted URL request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs650009

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yaws (PTS)stretch2.0.4+dfsg-1fixed
buster2.0.6+dfsg-1fixed
bullseye, sid2.0.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yawssourcelenny(not affected)
yawssourcesqueeze(not affected)
yawssource(unstable)1.91-2650009

Notes

[lenny] - yaws <not-affected> (Vulnerable code not present)
[squeeze] - yaws <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems