CVE-2011-4361

NameCVE-2011-4361
DescriptionMediaWiki before 1.17.1 does not check for read permission before handling action=ajax requests, which allows remote attackers to obtain sensitive information by (1) leveraging the SpecialUpload::ajaxGetExistsWarning function, or by (2) leveraging an extension, as demonstrated by the CategoryTree, ExtTab, and InlineEditor extensions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2366-1
NVD severitymedium (attack range: remote)
Debian Bugs650434
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)squeeze (security), squeeze1:1.15.5-2squeeze6fixed
wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3fixed
jessie, sid1:1.19.20+dfsg-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.15.5-4medium650434
mediawikisourcelenny1:1.12.0-2lenny9mediumDSA-2366-1
mediawikisourcesqueeze1:1.15.5-2squeeze2mediumDSA-2366-1

Notes

http://lists.wikimedia.org/pipermail/mediawiki-announce/2011-November/000104.html

Search for package or bug name: Reporting problems