CVE-2011-4364

NameCVE-2011-4364
DescriptionBuffer overflow in the Sierra VMD decoder in libavcodec in FFmpeg 0.5.x before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9 and 0.8.x before 0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x before 0.7.3 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted VMD file, related to corrupted streams.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2378-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.7-1~deb9u1fixed
stretch (security)7:3.2.8-1~deb9u1fixed
buster, sid7:3.3.4-2fixed
libav (PTS)wheezy6:0.8.17-2fixed
wheezy (security)6:0.8.20-0+deb7u1fixed
jessie (security), jessie6:11.9-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1medium
ffmpegsourcesqueeze4:0.5.6-3mediumDSA-2378-1
ffmpeg-debiansource(unstable)(unfixed)end-of-life
libavsource(unstable)4:0.7.3-1medium

Notes

http://www.usenix.org/events/woot11/tech/final_files/Yamaguchi.pdf
http://git.libav.org/?p=libav.git;a=commitdiff;h=494cfacdb9ba3f0549e37f76b3a2f86a7aeeac3c

Search for package or bug name: Reporting problems