CVE-2011-4407

NameCVE-2011-4407
Descriptionppa.py in Software Properties before 0.81.13.3 does not validate the server certificate when downloading PPA GPG key fingerprints, which allows man-in-the-middle (MITM) attackers to spoof GPG keys for a package repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
software-properties (PTS)stretch0.96.20.2-1fixed
stretch (security)0.96.20.2-1+deb9u1fixed
buster0.96.20.2-2fixed
bullseye, sid0.96.20.2-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
software-propertiessourcelenny(not affected)
software-propertiessourcesqueeze(not affected)
software-propertiessource(unstable)0.76.7debian2+nmu2

Notes

[squeeze] - software-properties <not-affected> (Vulnerable code not present)
[lenny] - software-properties <not-affected> (Vulnerable code not present)
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/915210/

Search for package or bug name: Reporting problems