CVE-2011-4625

NameCVE-2011-4625
Descriptionsimplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2330-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)jessie1.13.1-2+deb8u1fixed
jessie (security)1.13.1-2+deb8u3fixed
stretch1.14.11-1+deb9u1fixed
stretch (security)1.14.11-1+deb9u2fixed
buster, buster (security)1.16.3-1+deb10u1fixed
bullseye, sid1.18.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.8.1-1
simplesamlphpsourcesqueeze1.6.3-2DSA-2330-1

Search for package or bug name: Reporting problems