CVE-2011-4862

NameCVE-2011-4862
DescriptionBuffer overflow in libtelnet/encrypt.c in telnetd in FreeBSD 7.3 through 9.0, MIT Kerberos Version 5 Applications (aka krb5-appl) 1.0.2 and earlier, Heimdal 1.5.1 and earlier, GNU inetutils, and possibly other products allows remote attackers to execute arbitrary code via a long encryption key, as exploited in the wild in December 2011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2372-1, DSA-2373-1, DSA-2375-1
Debian Bugs654231

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)bullseye (security), bullseye7.7.0+dfsg-2+deb11u3fixed
bookworm7.8.git20221117.28daf24+dfsg-2fixed
sid, trixie7.8.git20221117.28daf24+dfsg-5fixed
inetutils (PTS)bullseye2:2.0-1+deb11u2fixed
bookworm2:2.4-2+deb12u1fixed
sid, trixie2:2.5-5fixed
krb5 (PTS)bullseye1.18.3-6+deb11u4fixed
bullseye (security)1.18.3-6+deb11u5fixed
bookworm1.20.1-2+deb12u1fixed
bookworm (security)1.20.1-2+deb12u2fixed
trixie1.21.2-1fixed
sid1.21.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsourcelenny1.2.dfsg.1-2.1+lenny1DSA-2372-1
heimdalsourcesqueeze1.4.0~git20100726.dfsg.1-2+squeeze1DSA-2372-1
heimdalsource(unstable)1.5.dfsg.1-1high
inetutilssourcelenny2:1.5.dfsg.1-9+lenny1DSA-2373-1
inetutilssourcesqueeze2:1.6-3.1+squeeze1DSA-2373-1
inetutilssource(unstable)2:1.8-6high
krb5sourcelenny1.6.dfsg.4~beta1-5lenny7DSA-2375-1
krb5source(unstable)1.8+dfsg~aa+r23527-1high
krb5-applsourcesqueeze1:1.0.1-1.2DSA-2375-1
krb5-applsource(unstable)1:1.0.1-1.2high654231

Notes

krb5 fixed through move of code to krb5-appl.

Search for package or bug name: Reporting problems