CVE-2011-4966

NameCVE-2011-4966
Descriptionmodules/rlm_unix/rlm_unix.c in FreeRADIUS before 2.2.0, when unix mode is enabled for user authentication, does not properly check the password expiration in /etc/shadow, which allows remote authenticated users to authenticate using an expired password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs694407

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)jessie (security), jessie2.2.5+dfsg-0.2+deb8u1fixed
stretch (security), stretch3.0.12+dfsg-5+deb9u1fixed
buster3.0.17+dfsg-1.1fixed
bullseye, sid3.0.19+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)2.1.12+dfsg-1.2low694407

Notes

[squeeze] - freeradius <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems