CVE-2011-5062

NameCVE-2011-5062
DescriptionThe HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 does not check qop values, which might allow remote attackers to bypass intended integrity-protection requirements via a qop=auth value, a different vulnerability than CVE-2011-1184.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2401-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)squeeze, squeeze (security)6.0.35-1+squeeze4fixed
squeeze (lts)6.0.41-2+squeeze7fixed
wheezy, wheezy (security)6.0.35-6+deb7u1fixed
jessie6.0.41-3fixed
stretch, sid6.0.41-4fixed
tomcat7 (PTS)wheezy, wheezy (security)7.0.28-4+deb7u1fixed
jessie7.0.56-3fixed
stretch7.0.61-1fixed
sid7.0.62-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat5.5source(unstable)(unfixed)medium
tomcat6source(unstable)6.0.32-7medium
tomcat6sourcesqueeze6.0.35-1+squeeze2mediumDSA-2401-1
tomcat7source(unstable)7.0.12medium

Search for package or bug name: Reporting problems