CVE-2011-5129

NameCVE-2011-5129
DescriptionHeap-based buffer overflow in XChat 2.8.9 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long response string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs686454

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xchat (PTS)wheezy2.8.8-7.1vulnerable
wheezy (security)2.8.8-7.1+deb7u1vulnerable
jessie2.8.8-7.3vulnerable
buster, sid2.8.8-11vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xchatsource(unstable)(unfixed)unimportant686454

Search for package or bug name: Reporting problems