CVE-2011-5244

NameCVE-2011-5244
DescriptionMultiple off-by-one errors in the (1) token and (2) linetoken functions in backend/dvi/mdvi-lib/afmparse.c in t1lib, as used in teTeX 3.0.x, GNOME evince, and possibly other products, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a DVI file containing a crafted Adobe Font Metrics (AFM) file, different vulnerabilities than CVE-2010-2642 and CVE-2011-0433.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2357-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
evince (PTS)stretch (security), stretch3.22.1-3+deb9u2fixed
buster, buster (security)3.30.2-3+deb10u1fixed
bullseye, sid3.38.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
evincesourcelenny2.22.2-4~lenny2DSA-2357-1
evincesourcesqueeze2.30.3-2+squeeze1
evincesource(unstable)2.32.0-1

Notes

This issue was already fixed in DSA-2357-1 by shipping the correct fix from the start

Search for package or bug name: Reporting problems