CVE-2011-5320

NameCVE-2011-5320
Descriptionscanf and related functions in glibc before 2.15 allow local users to cause a denial of service (segmentation fault) via a large string of 0s.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-165-1
NVD severitylow (attack range: local)
Debian Bugs553206

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster2.25-3fixed
sid2.25-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)2.13-25low553206
eglibcsourcesqueeze2.11.3-4+deb6u5lowDLA-165-1
glibcsource(unstable)2.15low

Notes

2.15 ist the first version recieving the fix, mark with upstream version which should
be handled correctly then by the tracker.
https://sourceware.org/bugzilla/show_bug.cgi?id=13138
http://www.openwall.com/lists/oss-security/2015/02/26/2
https://sourceware.org/git/?p=glibc.git;a=commitdiff;h=3f8cc204fdd0
CVE assigned specific to the https://sourceware.org/bugzilla/show_bug.cgi?id=13138#c4 issue

Search for package or bug name: Reporting problems