CVE-2012-0036

NameCVE-2012-0036
Descriptioncurl and libcurl 7.2x before 7.24.0 do not properly consider special ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-2398-1
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)squeeze7.21.0-2.1+squeeze7fixed
squeeze (security)7.21.0-2.1+squeeze8fixed
wheezy7.26.0-1+wheezy8fixed
wheezy (security)7.26.0-1+wheezy9fixed
jessie, sid7.36.0-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.24.0-1
curlsourcelenny7.18.2-8lenny6DSA-2398-1
curlsourcesqueeze7.21.0-2.1+squeeze1DSA-2398-1

Notes

[lenny] - curl <not-affected> (Only affects 7.20.0 to 7.23.1)
http://curl.haxx.se/docs/adv_20120124.html

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)