CVE-2012-0057

NameCVE-2012-0057
DescriptionPHP before 5.3.9 has improper libxslt security settings, which allows remote attackers to create arbitrary files via a crafted XSLT stylesheet that uses the libxslt output extension.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2399-1
NVD severitymedium (attack range: remote)
Debian Bugs656308

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u5fixed
jessie, jessie (security)5.6.24+dfsg-0+deb8u1fixed
sid5.6.26+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.3.9-1medium656308
php5sourcelenny5.2.6.dfsg.1-1+lenny14mediumDSA-2399-1
php5sourcesqueeze5.3.3-7+squeeze5mediumDSA-2399-1

Search for package or bug name: Reporting problems