CVE-2012-0060

NameCVE-2012-0060
DescriptionRPM before 4.9.1.3 does not properly validate region tags, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an invalid region tag in a package header to the (1) headerLoad, (2) rpmReadSignature, or (3) headerVerify function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-140-1
NVD severitymedium (attack range: remote)
Debian Bugs667031

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rpm (PTS)wheezy, wheezy (security)4.10.0-5+deb7u2fixed
jessie4.11.3-1.1fixed
buster, stretch, sid4.12.0.2+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rpmsource(unstable)4.9.1.3-1medium667031
rpmsourcesqueeze4.8.1-6+squeeze2mediumDLA-140-1

Notes

[squeeze] - rpm <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems