CVE-2012-0065

NameCVE-2012-0065
DescriptionHeap-based buffer overflow in the receive_packet function in libusbmuxd/libusbmuxd.c in usbmuxd 1.0.5 through 1.0.7 allows physically proximate attackers to execute arbitrary code via a long SerialNumber field in a property list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs656581

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
usbmuxd (PTS)jessie1.0.8+git20140527.e72f2f7-2fixed
stretch1.1.0-2fixed
buster, sid1.1.1~git20181007.f838cf6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
usbmuxdsource(unstable)1.0.7-2medium656581
usbmuxdsourcelenny(not affected)
usbmuxdsourcesqueeze(not affected)

Notes

[lenny] - usbmuxd <not-affected> (introduced in 1.0.7)
[squeeze] - usbmuxd <not-affected> (introduced in 1.0.7)

Search for package or bug name: Reporting problems