CVE-2012-0249

NameCVE-2012-0249
DescriptionBuffer overflow in the ospf_ls_upd_list_lsa function in ospf_packet.c in the OSPFv2 implementation in ospfd in Quagga before 0.99.20.1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a Link State Update (aka LS Update) packet that is smaller than the length specified in its header.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2459-1
NVD severitylow (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)squeeze, squeeze (security)0.99.20.1-0+squeeze5fixed
wheezy, wheezy (security)0.99.22.4-1+wheezy1fixed
jessie0.99.23.1-1fixed
stretch, sid0.99.24.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.20.1-1low
quaggasourcesqueeze0.99.20.1-0+squeeze1lowDSA-2459-1

Search for package or bug name: Reporting problems