CVE-2012-0250

NameCVE-2012-0250
DescriptionBuffer overflow in the OSPFv2 implementation in ospfd in Quagga before 0.99.20.1 allows remote attackers to cause a denial of service (daemon crash) via a Link State Update (aka LS Update) packet containing a network-LSA link-state advertisement for which the data-structure length is smaller than the value in the Length header field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2459-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy0.99.22.4-1+wheezy2fixed
wheezy (security)0.99.22.4-1+wheezy3fixed
jessie (security), jessie0.99.23.1-1+deb8u2fixed
stretch, sid1.0.20160315-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.20.1-1low
quaggasourcesqueeze0.99.20.1-0+squeeze1lowDSA-2459-1

Search for package or bug name: Reporting problems