CVE-2012-0255

NameCVE-2012-0255
DescriptionThe BGP implementation in bgpd in Quagga before 0.99.20.1 does not properly use message buffers for OPEN messages, which allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a message associated with a malformed Four-octet AS Number Capability (aka AS4 capability).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2459-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)squeeze (security), squeeze0.99.20.1-0+squeeze5fixed
wheezy, wheezy (security)0.99.22.4-1+wheezy1fixed
jessie0.99.23.1-1fixed
sid0.99.24.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.20.1-1medium
quaggasourcesqueeze0.99.20.1-0+squeeze1mediumDSA-2459-1

Search for package or bug name: Reporting problems