DescriptionCross-site scripting (XSS) vulnerability in wp-comments-post.php in WordPress 3.3.x before 3.3.1, when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via the query string in a POST operation that is not properly handled by the "Duplicate comment detected" feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.18+dfsg-1+deb9u1fixed
buster, buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.5.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcelenny(not affected)
wordpresssourcesqueeze(not affected)


[squeeze] - wordpress <not-affected> (only 3.3.x vulnerable)
[lenny] - wordpress <not-affected> (only 3.3.x vulnerable)

Search for package or bug name: Reporting problems