CVE-2012-0287

NameCVE-2012-0287
DescriptionCross-site scripting (XSS) vulnerability in wp-comments-post.php in WordPress 3.3.x before 3.3.1, when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via the query string in a POST operation that is not properly handled by the "Duplicate comment detected" feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1fixed
buster (security)5.0.21+dfsg1-0+deb10u1fixed
bullseye5.7.8+dfsg1-0+deb11u2fixed
bullseye (security)5.7.11+dfsg1-0+deb11u1fixed
bookworm6.1.1+dfsg1-1fixed
bookworm (security)6.1.6+dfsg1-0+deb12u1fixed
sid, trixie6.5.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcelenny(not affected)
wordpresssourcesqueeze(not affected)
wordpresssource(unstable)3.3.1+dfsg-1

Notes

[squeeze] - wordpress <not-affected> (only 3.3.x vulnerable)
[lenny] - wordpress <not-affected> (only 3.3.x vulnerable)

Search for package or bug name: Reporting problems