CVE-2012-0504

NameCVE-2012-0504
DescriptionUnspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 Update 2 and earlier, and 6 Update 30 and earlier, allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors related to Install and the Java Update mechanism.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-7 (PTS)jessie7u111-2.6.7-1~deb8u1fixed
jessie (security)7u181-2.6.14-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6source(unstable)(not affected)
openjdk-7source(unstable)(not affected)
sun-java6source(unstable)(not affected)

Notes

- openjdk-6 <not-affected> (Only applies to the Windows-specific update tool)
- openjdk-7 <not-affected> (Only applies to the Windows-specific update tool)
- sun-java6 <not-affected> (Only applies to the Windows-specific update tool)

Search for package or bug name: Reporting problems