CVE-2012-0805

NameCVE-2012-0805
DescriptionMultiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select function, or unspecified vectors to the (3) select.limit or (4) select.offset function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2449-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlalchemy (PTS)wheezy0.7.8-1fixed
jessie0.9.8+dfsg-0.1fixed
stretch1.0.15+ds1-1fixed
buster, sid1.1.11+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlalchemysource(unstable)0.6.7-1high
sqlalchemysourcesqueeze0.6.3-3+squeeze1highDSA-2449-1

Search for package or bug name: Reporting problems