CVE-2012-0806

NameCVE-2012-0806
DescriptionBuffer overflow in Bip 0.8.8 and earlier might allow remote authenticated users to execute arbitrary code via vectors involving a series of TCP connections that triggers use of many open file descriptors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2393-1
NVD severitymedium (attack range: remote)
Debian Bugs657217
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bip (PTS)squeeze (security), squeeze0.8.2-1squeeze4fixed
wheezy0.8.8-2fixed
jessie, sid0.8.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bipsource(unstable)0.8.8-2medium657217
bipsourcelenny(not affected)
bipsourcesqueeze0.8.2-1squeeze4mediumDSA-2393-1

Notes

[lenny] - bip <not-affected> (Maintainer reports vulnerable code not present)

Search for package or bug name: Reporting problems