DescriptionVP8 Codec SDK (libvpx) before 1.0.0 "Duclair" allows remote attackers to cause a denial of service (application crash) via (1) unspecified "corrupt input" or (2) by "starting decoding from a P-frame," which triggers an out-of-bounds read, related to "the clamping of motion vectors in SPLITMV blocks".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)wheezy1.1.0-1fixed
wheezy (security)1.1.0-1+deb7u1fixed
jessie (security)1.3.0-3+deb8u1fixed
stretch (security), stretch1.6.1-3+deb9u1fixed
buster, sid1.7.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsourcesqueeze(not affected)


[squeeze] - libvpx <not-affected> (Introduced in 0.9.7)

Search for package or bug name: Reporting problems