CVE-2012-0876

NameCVE-2012-0876
DescriptionThe XML parser (xmlparse.c) in expat before 2.1.0 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via an XML file with many identifiers with the same value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2525-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs663579, 687672
Debian/oldstablepackage xmlrpc-c is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)squeeze (security), squeeze2.0.1-7+squeeze1fixed
wheezy2.1.0-1+deb7u1fixed
jessie, sid2.1.0-6fixed
python2.6 (PTS)squeeze2.6.6-8fixed
squeeze (lts)2.6.6-8+deb6u3fixed
wheezy2.6.8-1.1fixed
xmlrpc-c (PTS)squeeze1.06.27-1.1vulnerable
wheezy1.16.33-3.2fixed
jessie, sid1.33.14-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsource(unstable)2.1.0~beta3-1medium663579
expatsourcesqueeze2.0.1-7+squeeze1mediumDSA-2525-1
python2.6source(unstable)(not affected)
xmlrpc-csource(unstable)1.16.33-3.2low687672

Notes

[squeeze] - xmlrpc-c <no-dsa> (Minor issue)
- python2.6 <not-affected> (configured with --with-system-expat since 2.6.6-4)

Search for package or bug name: Reporting problems