CVE-2012-1098

NameCVE-2012-1098
DescriptionCross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs668977

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster, sid2:4.2.9-4fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.3.14medium
railssourcesqueeze(not affected)
ruby-actionpack-2.3source(unstable)2.3.14-3medium668977

Notes

[squeeze] - rails <not-affected> (Vulnerable code not present)
(code lives within ruby-actionpack in unstable)

Search for package or bug name: Reporting problems