CVE-2012-1108

NameCVE-2012-1108
DescriptionThe parse function in ogg/xiphcomment.cpp in TagLib 1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted vendorLength field in an ogg file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs662705

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
taglib (PTS)stretch1.11.1+dfsg.1-0.1fixed
stretch (security)1.11.1+dfsg.1-0.3+deb9u1fixed
buster1.11.1+dfsg.1-0.3+deb10u1fixed
bullseye1.11.1+dfsg.1-3fixed
bookworm, sid1.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
taglibsource(unstable)1.7.1-1low662705

Notes

[squeeze] - taglib <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems