CVE-2012-1142

NameCVE-2012-1142
DescriptionFreeType before 2.4.9, as used in Mozilla Firefox Mobile before 10.0.4 and other products, allows remote attackers to cause a denial of service (invalid heap write operation and memory corruption) or possibly execute arbitrary code via crafted glyph-outline data in a font.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2428-1
NVD severityhigh
Debian Bugs662864

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freetype (PTS)stretch2.6.3-3.2+deb9u1fixed
stretch (security)2.6.3-3.2+deb9u2fixed
buster, buster (security)2.9.1-3+deb10u2fixed
bullseye, sid2.10.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freetypesourcesqueeze2.4.2-2.1+squeeze4DSA-2428-1
freetypesource(unstable)2.4.9-1662864

Search for package or bug name: Reporting problems