CVE-2012-1151

NameCVE-2012-1151
DescriptionMultiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2431-1
NVD severitymedium (attack range: remote)
Debian Bugs661536
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbd-pg-perl (PTS)squeeze (security), squeeze2.17.1-2+squeeze1fixed
wheezy2.19.2-2fixed
jessie, sid3.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdbd-pg-perlsource(unstable)2.19.0-1medium661536
libdbd-pg-perlsourcesqueeze2.17.1-2+squeeze1mediumDSA-2431-1

Search for package or bug name: Reporting problems