CVE-2012-1152

NameCVE-2012-1152
DescriptionMultiple format string vulnerabilities in the error reporting functionality in the YAML::LibYAML (aka YAML-LibYAML and perl-YAML-LibYAML) module 0.38 for Perl allow remote attackers to cause a denial of service (process crash) via format string specifiers in a (1) YAML stream to the Load function, (2) YAML node to the load_node function, (3) YAML mapping to the load_mapping function, or (4) YAML sequence to the load_sequence function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2432-1
NVD severitymedium (attack range: remote)
Debian Bugs661548

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libyaml-libyaml-perl (PTS)wheezy, wheezy (security)0.38-3+deb7u3fixed
jessie0.41-6fixed
buster, sid, stretch0.63-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libyaml-libyaml-perlsource(unstable)0.38-2medium661548
libyaml-libyaml-perlsourcesqueeze0.33-1+squeeze1mediumDSA-2432-1

Search for package or bug name: Reporting problems