CVE-2012-1163

NameCVE-2012-1163
DescriptionInteger overflow in the _zip_readcdir function in zip_open.c in libzip 0.10 allows remote attackers to execute arbitrary code via the size and offset values for the central directory in a zip archive, which triggers "improper restrictions of operations within the bounds of a memory buffer" and an information leak.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs664990

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzip (PTS)jessie0.11.2-1.2fixed
stretch1.1.2-1.1fixed
bullseye, sid, buster1.5.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzipsource(unstable)0.10.1-1medium664990
libzipsourcesqueeze(not affected)

Notes

[squeeze] - libzip <not-affected> (Only affects 0.10.x)

Search for package or bug name: Reporting problems