CVE-2012-1164

NameCVE-2012-1164
Descriptionslapd in OpenLDAP before 2.4.30 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via an LDAP search query with attrsOnly set to true, which causes empty attributes to be returned.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-203-1
NVD severitylow (attack range: remote)
Debian Bugs663644

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)wheezy2.4.31-2+deb7u2fixed
wheezy (security)2.4.31-2+deb7u3fixed
jessie (security), jessie2.4.40+dfsg-1+deb8u3fixed
stretch2.4.44+dfsg-5+deb9u1fixed
buster, sid2.4.45+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)2.4.31-1low663644
openldapsourcesqueeze2.4.23-7.3+deb6u1lowDLA-203-1

Notes

[squeeze] - openldap <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2012/03/12/4

Search for package or bug name: Reporting problems