CVE-2012-1177

NameCVE-2012-1177
Descriptionlibgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2482-1
NVD severitymedium (attack range: remote)
Debian Bugs664032
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgdata (PTS)squeeze (security), squeeze0.6.4-2+squeeze1fixed
wheezy0.12.0-1fixed
jessie, sid0.16.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgdatasource(unstable)0.10.2-1medium664032
libgdatasourcesqueeze0.6.4-2+squeeze1mediumDSA-2482-1

Notes

http://www.openwall.com/lists/oss-security/2012/03/14/3

Search for package or bug name: Reporting problems