CVE-2012-1502

NameCVE-2012-1502
DescriptionDouble free vulnerability in the PyPAM_conv in PAMmodule.c in PyPam 0.5.0 and earlier allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a NULL byte in a password string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2430-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pam (PTS)wheezy0.4.2-13fixed
jessie0.4.2-13.1fixed
buster, sid, stretch0.4.2-13.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pamsource(unstable)0.4.2-13high
python-pamsourcesqueeze0.4.2-12.2+squeeze1highDSA-2430-1

Search for package or bug name: Reporting problems