CVE-2012-1571

NameCVE-2012-1571
Descriptionfile before 5.11 and libmagic allow remote attackers to cause a denial of service (crash) via a crafted Composite Document File (CDF) file that triggers (1) an out-of-bounds read or (2) an invalid pointer dereference.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2422-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs664263
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)squeeze (security), squeeze5.04-5+squeeze5fixed
squeeze (lts)5.04-5+squeeze9fixed
wheezy5.11-2+deb7u6fixed
wheezy (security)5.11-2+deb7u7fixed
jessie1:5.20-2fixed
sid1:5.22+15-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)5.11-1low664263
filesourcesqueeze5.04-5+squeeze1mediumDSA-2422-1

Search for package or bug name: Reporting problems