CVE-2012-1573

NameCVE-2012-1573
Descriptiongnutls_cipher.c in libgnutls in GnuTLS before 2.12.17 and 3.x before 3.0.15 does not properly handle data encrypted with a block cipher, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) via a crafted record, as demonstrated by a crafted GenericBlockCipher structure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2441-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)stretch3.5.8-5+deb9u5fixed
stretch (security)3.5.8-5+deb9u1fixed
buster3.6.7-4+deb10u5fixed
buster (security)3.6.7-4+deb10u4fixed
bullseye, sid3.6.15-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26sourcesqueeze2.8.6-1+squeeze2DSA-2441-1
gnutls26source(unstable)2.12.18-1high
gnutls28source(unstable)3.0.17-2high

Search for package or bug name: Reporting problems