CVE-2012-1608

NameCVE-2012-1608
DescriptionThe t3lib_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote attackers to bypass the cross-site scripting (XSS) protection mechanism and inject arbitrary web script or HTML via non printable characters.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2445-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
typo3-src (PTS)squeeze (security), squeeze4.3.9+dfsg1-1+squeeze9fixed
wheezy4.5.19+dfsg1-5+wheezy3fixed
wheezy (security)4.5.19+dfsg1-5+wheezy4fixed
sid4.5.40+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
typo3-srcsource(unstable)4.5.14+dfsg1-1medium
typo3-srcsourcesqueeze4.3.9+dfsg1-1+squeeze3mediumDSA-2445-1

Search for package or bug name: Reporting problems