CVE-2012-1610

NameCVE-2012-1610
DescriptionInteger overflow in the GetEXIFProperty function in magick/property.c in ImageMagick before 6.7.6-4 allows remote attackers to cause a denial of service (out-of-bounds read) via a large component count for certain EXIF tags in a JPEG image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0259.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2462-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs667635
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)squeeze (security), squeeze8:6.6.0.4-3+squeeze4fixed
squeeze (lts)8:6.6.0.4-3+squeeze5fixed
wheezy, wheezy (security)8:6.7.7.10-5+deb7u3fixed
jessie, sid8:6.8.9.9-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.7.4.0-4medium667635
imagemagicksourcesqueeze8:6.6.0.4-3+squeeze3mediumDSA-2462-1

Search for package or bug name: Reporting problems