CVE-2012-1618

NameCVE-2012-1618
DescriptionInteraction error in the PostgreSQL JDBC driver before 8.2, when used with a PostgreSQL server with the "standard_conforming_strings" option enabled, such as the default configuration of PostgreSQL 9.1, does not properly escape unspecified JDBC statement parameters, which allows remote attackers to perform SQL injection attacks. NOTE: as of 20120330, it was claimed that the upstream developer planned to dispute this issue, but an official dispute has not been posted as of 20121005.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpgjava (PTS)buster42.2.5-2+deb10u1fixed
buster (security)42.2.5-2+deb10u3fixed
bullseye (security), bullseye42.2.15-1+deb11u1fixed
bookworm42.5.4-1fixed
trixie42.7.1-1fixed
sid42.7.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpgjavasource(unstable)(not affected)

Notes

- libpgjava <not-affected> (Even the version in oldstable had 8.2)

Search for package or bug name: Reporting problems