CVE-2012-1663

NameCVE-2012-1663
DescriptionDouble free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch3.5.8-5+deb9u3fixed
stretch (security)3.5.8-5+deb9u1fixed
buster, sid3.5.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)(not affected)
gnutls28source(unstable)3.0.14-1high

Notes

- gnutls26 <not-affected> (only GNUTLS 3.0 is affected)

Search for package or bug name: Reporting problems