CVE-2012-1719

NameCVE-2012-1719
DescriptionUnspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 update 4 and earlier, 6 update 32 and earlier, 5 update 35 and earlier, and 1.4.2_37 and earlier allows remote attackers to affect integrity, related to CORBA.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2507-1
NVD severitymedium (attack range: remote)
Debian Bugs677486, 677487
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-6 (PTS)squeeze6b18-1.8.13-0+squeeze2fixed
squeeze (security)6b31-1.13.3-1~deb6u1fixed
squeeze (lts)6b36-1.13.8-1~deb6u1fixed
wheezy6b27-1.12.5-1fixed
wheezy (security)6b36-1.13.8-1~deb7u1fixed
openjdk-7 (PTS)wheezy7u3-2.1.7-1fixed
wheezy (security)7u79-2.5.6-1~deb7u1fixed
stretch, jessie7u75-2.5.4-2fixed
jessie (security)7u79-2.5.6-1~deb8u1fixed
sid7u85-2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6source(unstable)6b24-1.11.3-1medium677487
openjdk-6sourcesqueeze6b18-1.8.13-0+squeeze2mediumDSA-2507-1
openjdk-7source(unstable)7~u3-2.1.1-1medium677486

Search for package or bug name: Reporting problems