CVE-2012-1776

NameCVE-2012-1776
DescriptionMultiple heap-based buffer overflows in VideoLAN VLC media player before 2.0.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Real RTSP stream.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.6-1~deb8u1fixed
jessie (security)2.2.7-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
stretch (security)2.2.7-1~deb9u1fixed
buster, sid2.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.0.1-1low
vlcsourcesqueeze(unfixed)end-of-life

Notes

[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems