CVE-2012-1939

NameCVE-2012-1939
Descriptionjsinfer.cpp in Mozilla Firefox ESR 10.x before 10.0.5 and Thunderbird ESR 10.x before 10.0.5 does not properly determine data types, which allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via crafted JavaScript code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.7.0-1~deb7u1fixed
jessie (security), jessie31.7.0-1~deb8u1fixed
stretch, sid31.7.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.8.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.8.0esr-1~deb8u1fixed
stretch38.0.1-5fixed
sid38.1.0esr-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)10.0.5-1high
icedovesourcesqueeze(not affected)
iceweaselsource(unstable)10.0.5esr-1high
iceweaselsourcesqueeze(not affected)

Notes

[squeeze] - iceweasel <not-affected> (Vulnerable code not present)
[squeeze] - icedove <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems