CVE-2012-1947

NameCVE-2012-1947
DescriptionHeap-based buffer overflow in the utf16_to_isolatin1 function in Mozilla Firefox 4.x through 12.0, Firefox ESR 10.x before 10.0.5, Thunderbird 5.0 through 12.0, Thunderbird ESR 10.x before 10.0.5, and SeaMonkey before 2.10 allows remote attackers to execute arbitrary code via vectors that trigger a character-set conversion failure.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2488-1, DSA-2489-1, DSA-2499-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
jessie, stretch, sid31.6.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
jessie, stretch, sid31.6.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesourcesqueeze2.0.11-13highDSA-2489-1
icedovesource(unstable)10.0.5-1high
icedovesourcesqueeze3.0.11-1+squeeze11highDSA-2499-1
iceweaselsource(unstable)10.0.5esr-1high
iceweaselsourcesqueeze3.5.16-16highDSA-2488-1

Notes

[squeeze] - iceweasel <not-affected> (Vulnerable code not present)
[squeeze] - icedove <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems