CVE-2012-2101

NameCVE-2012-2101
DescriptionOpenstack Compute (Nova) Folsom, 2012.1, and 2011.3 does not limit the number of security group rules, which allows remote authenticated users with certain permissions to cause a denial of service (CPU and hard drive consumption) via a network request that triggers a large number of iptables rules.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs670637

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nova (PTS)buster2:18.1.0-6fixed
buster (security)2:18.1.0-6+deb10u2fixed
bullseye (security), bullseye2:22.0.1-2+deb11u1fixed
bookworm2:26.1.0-4fixed
trixie2:29.0.1-6fixed
sid2:29.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
novasource(unstable)2012.1-2670637

Search for package or bug name: Reporting problems