CVE-2012-2107

NameCVE-2012-2107
DescriptionInteger overflow in the main function in util/lpci_main.c in Csound before 5.17.2, when converting a file, allows user-assisted remote attackers to execute arbitrary code via a crafted file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs661197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
csound (PTS)stretch1:6.08.0~dfsg-1fixed
buster1:6.12.2~dfsg-3.1fixed
bullseye, sid1:6.14.0~dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
csoundsource(unstable)1:5.17.6~dfsg-1661197

Notes

[squeeze] - csound <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems