CVE-2012-2113

NameCVE-2012-2113
DescriptionMultiple integer overflows in tiff2pdf in libtiff before 4.0.2 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted tiff image, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2552-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs678140
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)squeeze, squeeze (security)3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze12fixed
wheezy4.0.2-6+deb7u3fixed
wheezy (security)4.0.2-6+deb7u4fixed
jessie4.0.3-12.3fixed
stretch, sid4.0.3-13fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.2-1medium678140
tiffsourcesqueeze3.9.4-5+squeeze5mediumDSA-2552-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (The tiff-tools package is only built from the tiff source package)

Search for package or bug name: Reporting problems